Google
 
Strona główna Darmowe programy, shareware Programowanie MS Excel Porady komputerowe Bazy danych Kontakt

Excel formuły


Excel formuły



Wykorzystanie formuły do filtrowania zaawansowanego



Czasami zachodzi potrzeba przefiltrowania danych według kryteriów, których złożoność przekracza możliwości autofiltru niestandardowego. Można wtedy wykorzystać formuły do zdefiniowania tych kryteriów.

Rozpatrzmy następujący przykład.

W arkuszu znajdują się następujące dane:

Przykład wykorzystania formuł Excela do filtrowania

Chcemy przefiltrować tych klientów, którzy złożyli zamówienie na kwotę powyżej 300 PLN i zapłacili mniej niż 50% kwoty zamówienia.



W komórce D2 wpisujemy następującą formułę:

=JEŻELI(ORAZ($B2>300;($C2)*100/$B2<50);1;0)

Oznacza ona następujące działanie: Jeżeli w komórce B2 jest wartość większa od 300 oraz w komórce C2 jest wartość mniejsza niż 50% wartości komórki B2 to w komórkę D2 wpisz 1; w przeciwnym wypadku wpisz 0.

Po rozciągnięciu komórki D2 do ostatniego wiersza danych w kolumnie D pojawią się wartości formuły dla każdego wiersza.

Przykład wykorzystania formuł  Excela do filtrowania


Teraz już bardzo łatwo przefiltrować wiersze spełniające nasze kryteria (wykorzystujemy do tego autofiltr):

Przykład wykorzystania formuł Excela do filtrowania




Zobacz także...

Tabele przestawne
Formatowanie warunkowe Excel
Excel suma
Excel funkcja jeżeli
Excel - funkcje
Excel - makra
Wykonywanie obliczeń na serii danych, wykorzystanie funkcji
Excel - "Szukaj wyniku"
Excel - wykresy funkcji
Excel - import danych
Excel - filtrowanie danych




Blok czekoladowy - przepis
Polecamy przepis na blok czekoladowy - pyszny deser o waniliowo-mlecznym smaku. Blok czekoladowy - przepis
 

Copyright © 2006-2010 programowaniePC.pl